Preparing for Couchbase Lite on Android

    +

    Description — Prerequisites for the installation of Couchbase Lite
    Abstract — Laying out some of the pre-requisites and preparatory steps to be considered before installing Couchbase Lite for java-android

    Supported Versions

    The operating systems listed below refer to "Certified" versions of Android. We do not test against, nor guarantee support for, uncertified Android versions such as versions built from source.

    Deprecation Notice

    Support for API 19 and 21 was deprecated in release 2.6 and will be removed in a future release

    Action: Please plan to migrate your apps to use API versions greater than API 21

    Platform Runtime architectures Minimum API Level

    Android

    armeabi-v7a

    22

    Android

    arm64-v8a

    22

    Android

    x86

    22

    Android

    x86_64

    22