Field Level Encryption from the SDK

    +
    Fields within a document can be securely encrypted by the SDK, to support FIPS-140-2 compliance.

    Client-side implementation of Field Level Encryption is available in the 3.x Java version of the SDK. It will be enabled in a future release of the other third generation SDKs.

    Field Level Encryption is normally carried out at a higher level than libcouchbase (LCB). It will be available in a later release of the LCB 'wrapper' SDKs: Node.js, PHP, Python. It will not be available in LCB.